1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

Kein AC3 2.0 Ton nach muxen mit ImagoMPEG

Dieses Thema im Forum "Digitale Audio- und Videobearbeitung" wurde erstellt von rolle-rolle, 17. Dezember 2013.

  1. rolle-rolle

    rolle-rolle Neuling

    Registriert seit:
    11. Dezember 2013
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Anzeige
    Hallo,

    ich habe meine Filme von einem TechniSat HD Vision exportiert (dabei gehlt leider das 5.1 Signal verloren und es bleibt ein 2.0 Signal). Diese habe ich mit ProjectX erfolgreich demuxed. Sowohl die m2v Videodatei, die mp2 Dateien und ac3 Datei lassen sich am PC und an meinem WD TV live Medienplayer abspielen.
    Anschließend muxe ich die Dateien mit ImagoMPEG. Ich gebe die Videodatei ein, die Audiodateien lädt das Programm dann selbständig ein, die ac3 Datei als letztes.
    Als Ergebnis erhalte ich entweder eine mpg Videodatei oder eine vob DVD Datei. In beiden Fällen kann ich mit dem Medienplayer zwar die Tonspur auswählen, aber für die beiden letzten Tonspuren wird kein Ton ausgegeben.
    Kann mir bitte jemand sagen, woran das liegt?

    Danke und Grüße
    Rolle
     
  2. may24

    may24 Silber Member

    Registriert seit:
    15. Februar 2011
    Beiträge:
    709
    Zustimmungen:
    21
    Punkte für Erfolge:
    28
    AW: Kein AC3 2.0 Ton nach muxen mit ImagoMPEG

    Lass das doch bitte mal kurz duch Mediainfo laufen ...
     
  3. rolle-rolle

    rolle-rolle Neuling

    Registriert seit:
    11. Dezember 2013
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Kein AC3 2.0 Ton nach muxen mit ImagoMPEG

    Hallo may24,

    MediaInfo:
    Allgemein
    Vollständiger Name : Test.mpg
    Format : MPEG-PS
    Dateigröße : 1,80 GiB
    Dauer : 52min
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 4 922 Kbps

    Video
    ID : 224 (0xE0)
    Format : MPEG Video
    Format-Version : Version 2
    Format-Profil : Main@Main
    Format-Einstellungen für BVOP : Ja
    Format-Einstellungen für Matrix : ausgewählt
    Format_Settings_GOP : M=3, N=12
    Dauer : 52min
    Bitraten-Modus : variabel
    Bitrate : 3 736 Kbps
    Breite : 720 Pixel
    Höhe : 576 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 25,000 FPS
    Standard : PAL
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : Interlaced
    Scanreihenfolge : oberes Feld zuerst
    Bits/(Pixel*Frame) : 0.360
    TimeCode_FirstFrame : 00:00:00:00
    TimeCode_Source : Group of pictures header
    Stream-Größe : 1,37 GiB (76%)

    Audio #1
    ID : 192 (0xC0)
    Format : MPEG Audio
    Format-Version : Version 1
    Format-Profil : Layer 2
    Dauer : 52min
    Bitraten-Modus : konstant
    Bitrate : 192 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 48,0 KHz
    Stream-Größe : 72,0 MiB (4%)

    Audio #2
    ID : 193 (0xC1)
    Format : MPEG Audio
    Format-Version : Version 1
    Format-Profil : Layer 2
    Dauer : 52min
    Bitraten-Modus : konstant
    Bitrate : 192 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 48,0 KHz
    Stream-Größe : 72,0 MiB (4%)

    Audio #3
    ID : 194 (0xC2)
    Format : MPEG Audio
    Format-Version : Version 1
    Format-Profil : Layer 2
    Dauer : 52min
    Bitraten-Modus : konstant
    Bitrate : 256 Kbps
    Kanäle : 2 Kanäle
    Samplingrate : 48,0 KHz
    Stream-Größe : 96,1 MiB (5%)

    Audio #4
    ID : 189 (0xBD)-131 (0x83)
    Format : AC-3
    Format/Info : Audio Coding 3
    Format_Settings_ModeExtension : CM (complete main)
    Format-Einstellungen für Endianess : Big
    Muxing-Modus : DVD-Video
    Dauer : 52min
    Bitraten-Modus : konstant
    Bitrate : 448 Kbps
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 48,0 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 168 MiB (9%)

    VLC gibt mir folgende Info:
    Stream 0
    Typ: Untertitel
    Codec: Text subtitles with various tags (subt)
    Stream 1
    Typ: Video
    Codec: MPEG-1/2 Video (mpgv)
    Auflösung: 720x576
    Bildwiederholrate: 25
    Decodiertes Format: Planar 4:2:0 YUV
    Stream 2
    Typ: Audio
    Codec: MPEG Audio layer 1/2/3 (mpga)
    Kanäle: Stereo
    Abtastrate: 48000 Hz
    Bitrate: 192 kB/s
    Stream 3
    Typ: Audio
    Codec: MPEG layer 1/2/3 (mpga)
    Stream 4
    Typ: Audio
    Codec: MPEG layer 1/2/3 (mpga)
    Stream 5
    Typ: Audio
    Codec: A52 Audio (aka AC3) (a52)


    Liegt eine AC3 Spur mit 5.1 Ausgangssignal vor dann bekomme ich folgende Info:
    Stream 4
    Typ: Audio
    Codec: A52 Audio (aka AC3) (a52)
    Kanäle: 3F2R/LFE
    Abtastrate: 48000 Hz
    Bitrate: 448 kB/s


    Beide Filme sind via DVB-S vom ZDF aufgenommen worden.

    Grüße und Danke für die Hilfe
     
    Zuletzt bearbeitet: 18. Dezember 2013
  4. rolle-rolle

    rolle-rolle Neuling

    Registriert seit:
    11. Dezember 2013
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Kein AC3 2.0 Ton nach muxen mit ImagoMPEG

    So, nun klappt es doch noch alles.
    Zum Muxen habe ich nicht ImagoMPEG verwendet, sondern mit MKVMerge aus dem Paket MKVTollNix eine MKV Datei erzeugt. Diese Dateien werden ohne Ruckeln und mit 5.1 Ton vom WD TV live abgespielt.
    Bei Verwendung des WD TV muss evtl. noch etwas beachtet werden, das habe ich hier http://forum.digitalfernsehen.de/fo...chnisat-hd-vision-pvr-export.html#post6291164 beschrieben.

    Grüße und Danke für die Hilfe
    Rolle
     
  5. Meyer2000

    Meyer2000 Gold Member

    Registriert seit:
    10. Februar 2010
    Beiträge:
    1.194
    Zustimmungen:
    47
    Punkte für Erfolge:
    58
  6. may24

    may24 Silber Member

    Registriert seit:
    15. Februar 2011
    Beiträge:
    709
    Zustimmungen:
    21
    Punkte für Erfolge:
    28
    AW: Kein AC3 2.0 Ton nach muxen mit ImagoMPEG

    Den TSDoctor brauchst du dafür nicht. Aber anschauen könnte sich trotzdem lohnen ;)

    Du kannst auch den TsMuxer nehmen, alles demuxen und die Teile die du brauchst in MKVMerge ziehen ... braucht du wirklich alle Tonspuren ?
     
  7. rolle-rolle

    rolle-rolle Neuling

    Registriert seit:
    11. Dezember 2013
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Kein AC3 2.0 Ton nach muxen mit ImagoMPEG

    Hallo May24,

    natürlich brauche ich jetzt nicht alle Tonspuren. Aber warum werden die Tonspuren denn gesendet?
    Soviel Platz brauchen sie ja nun nicht im Vergleich zur Bildspur.
    Und zwei Tonspuren braucht man ja dann doch (z.B. Stereo und 5.1). Oder worauf möchtest Du hinaus?

    Grüße
    Rolle

    PS: @Meyer2000
    Solange ich keine Garantie dafür bekomme, dass ich mit der gekauften Software ausnahmslos alle Datenformate bearbeiten, konvertieren und exportieren kann. Oder das Konvertieren quasi von alleine geht und das Endergebnis ohne Probleme auf jeder Hardware abspielbar ist, solange fällt es mir schwer eine Software zu bezahlen und am Ende habe ich doch ähnliche Probleme wie mit einer freier Software. Sorry, aber das habe ich schon hinter mir.
     
  8. may24

    may24 Silber Member

    Registriert seit:
    15. Februar 2011
    Beiträge:
    709
    Zustimmungen:
    21
    Punkte für Erfolge:
    28
    AW: Kein AC3 2.0 Ton nach muxen mit ImagoMPEG

    @rolle-rolle: Sei beruhigt, du wirst dann nie Geld für Software ausgeben, denn Eine SW die das Alles macht gibt's nicht und wird's auch nie geben ;)

    Zum Rest: Ok, es kommt drauf an was dein Player macht. Der PC/Mac kann/macht alles mit. Entsprechendes "DeCoding Pack" vorausgesetzt (und damit meine ich NICHT K-Light oder CCCP !!!). Installiere da besser ffdshow oder LAV Filters.
    Aber - gehen wir mal von AC3 aus, das ist z.Z. das "geräuchlichste" Mehrkanal Ton Format - das ist quasi "Stereo Kompatibel". D.h. wenn die Mehrkanalspur decodiert wird, das Gerät aber nur Stereo kann, wird halt der Rest verworfen ...
    Wozu also die Stereo Spur aufheben ?
    Wenn du also nichts schneiden oder Filtern willst, dann demux Alles, such dir aus was du brauchst und muxe es danach in einen Matroska (.mkv) Container. Das spart jede Menge Platz ohne das Ganze neu codieren zu müssen/wollen.
     

Diese Seite empfehlen