1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

Hilfe: VirtualDub - Audio will nicht so wie ich es gerne hätte

Dieses Thema im Forum "Digitale Audio- und Videobearbeitung" wurde erstellt von Petra1979, 27. Dezember 2006.

  1. Petra1979

    Petra1979 Neuling

    Registriert seit:
    27. Dezember 2006
    Beiträge:
    1
    Anzeige
    Hallo,
    ich habe in VirtualDub (v1.6.17) ca. 7 avi's aneinandergereiht. Bei fast jedem Einzelvideo ein paar Sekunden/Frames entfernt (damit auf dem Ausgangsvideo nur das wichtigste oben ist).


    Als Audiospur habe ich ein (eigenständiges) *.wav file verwendet. XviD als Videokompression genomen - Rendering hat geklappt!


    LEIDER wurden aus dem externen Audiofile die selben Teile entfernt, die ich zuvor händisch aus den aneinandergereihten Einzelvideos gelöscht habe. Wieso - ich habe ja nur die Videos und nicht das externe Audiofile beschnitten! Gibt es eine Möglichkeit in den Settings diesen Umstand zu umgehen?


    Danke für Eure Hilfe!
    PS: Gibt es ähnliche / bessere Freeware-Programme wie VirtualDub (zum zusammenfügen, schneiden, 'vertonen' mit DivX/XviD Kompression) falls das Problem nicht umgehbar sein sollte?
     
    Zuletzt bearbeitet: 27. Dezember 2006
  2. radio

    radio Senior Member

    Registriert seit:
    27. Mai 2004
    Beiträge:
    402
    Ort:
    Bremen
    AW: Hilfe: VirtualDub - Audio will nicht so wie ich es gerne hätte

    Dieses Verhalten ist vollkommen richtig, sonst hätte man bei Filmen den Ton nicht mehr synchron.
    Bleibt nur die Tonspur mit einem anderen Programm auf die Länge des Videos zu schneiden und dann mit Virtualdub diese Tonspur und das Video zu multiplexen.
    Man kann dazu vorher das Video nochmal ohne Ton abspeichern und dann als Audio-Quelle diese Wave Datei auswählen. Audio Komprimierung einstellen, Video auf direct stream copy und abspeichern.
    Es gibt unter Optionen auch die Möglichkeit "sync to audio" auszuschalten, das habe ich aber nie ausprobiert.
     
  3. HarryPotter

    HarryPotter Wasserfall

    Registriert seit:
    17. Oktober 2002
    Beiträge:
    8.791
    Ort:
    Kyffhäuserkreis
    AW: Hilfe: VirtualDub - Audio will nicht so wie ich es gerne hätte

    Konnte man bei Audio nicht früher immer "Direct Stream Copy" einstellen? Dann wird die Spur doch nicht geschnitten oder liege ich da falsch?
     
    Zuletzt bearbeitet: 28. Dezember 2006

Diese Seite empfehlen