1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

Windows 2000 Server und SuSE Linux für Lokal-Web

Dieses Thema im Forum "Small Talk" wurde erstellt von Michael, 23. Juni 2002.

  1. Michael

    Michael Platin Member

    Registriert seit:
    29. Januar 2001
    Beiträge:
    2.936
    Ort:
    Erkner bei Berlin
    Technisches Equipment:
    DM800, AZBox HD, Elanvision, Openbox...
    Anzeige
    Hi Folks!

    etwas OT aber naja ... hier sind doch die wahren Wissenden ... in den Linux-Boards treibt sich selten ein echter Wissender rum winken

    Mein Problem:
    Ich habe als Internet-Router ein Windows 2000 Server (ohne IIS), der gleichzeitig DHCP macht.
    Weiterhin habe ich eine SuSE 7.1 (Kernel 2.4.0), die Filesharing (smbd) und verschiedene virtuelle Webserver anzeigen soll (httpd).

    Zur Erklärung:
    Windows 2000 Server nehme ich für Internetz, da Linux (bekanntermaßen) nicht mit der Eumex-Telefon-Anlage klar kommt. Und damit der Router nicht so vor sich hin idelt, verteilt er auch erfolgreich die IP-Adressen im LAN (DHCP)
    SuSE ist so konfiguriert, dass in deren /etc/hosts 4 verschiedene Domainnamen eingetragen sind, die in der /etc/httpd/httpd.conf als virtuelle Server in verschiedenen Verzeichnisse auf der SuSE verteilt sind.

    Zur Frage:
    Ich sitze an einer Workstation, die von Windows2000 eine IP erhält und die DNS mitgeteilt bekommt (für LAN: 192.168.0.1 - Win2K und für Web: 194.64.64.1 - Snafu)
    Öffne ich nun den Browser und gebe eine der virtuellen Adressen ein (z.B. satbook - ohne www und de), dann sollte sich vor mir das virtuelle Verzeichnis der SuSE auftun, was leider nicht der Fall ist. Statt dessen erscheint ein Error 500 (interner Serverfehler).

    Von der SuSE kann dieser Fehler nicht stammen. Die sagt mir im Error-Log bzw. Access-Log, dass niemand auf das Verzeichnis zugegriffen habe.
    Vom Windows 2000 Server kann das aber auch nicht stammen, da ich keinen IIS installiert habe. Und ein anderer Webserver läuft auch nicht auf dem Win2K.

    Woher kommt nun dieser Error 500? Aus dem Web kann er ja auch nicht kommen, da eine Error 404-Seite kommen müsste.

    Die Verzeichnisse auf der SuSE sind korrekt angelegt worden. Haben alle chmod 755 ... also sollten angezeigt werden.

    Kann mir jemand helfen?

    Tausend Dank schonmal im Vorraus läc

    Micha

    <small>[ 23. Juni 2002, 23:24: Beitrag editiert von: Michael ]</small>
     
  2. Michael

    Michael Platin Member

    Registriert seit:
    29. Januar 2001
    Beiträge:
    2.936
    Ort:
    Erkner bei Berlin
    Technisches Equipment:
    DM800, AZBox HD, Elanvision, Openbox...
    Problem hat sich teilweise gelöst l&auml;c
    Hab einfach die Datei HOSTS.SAM (C:\WINDOWS) in HOSTS umbenannt und dort die entsprechenden Domains mit der IP der SuSE versehen ... allerdings ist das auf Dauer nicht der Bringer ... zumal das ja bei allen Rechnern im LAN geschehen muss entt&aum
     
  3. zahni

    zahni Board Ikone

    Registriert seit:
    22. Januar 2001
    Beiträge:
    3.940
    Ort:
    MD
    Unter der Voraussetzung, das DNS richtig geht (sorry, ich blicke bei Deiner Beschreibung nicht ganz durch), muss Dein httpd richtig konfiguriert sein. Er muss den http-host-haeder richtig auswerten. Wenn da z.B. nur www.server.com drinn steht und Du kommmst mit server.com leitet Dich der httpd je nach config entweder auf eine Defaultseite oder bringt eben einen error. PS: ich habe Ganze bisher nur mal mit dem IIS getestet.

    -Zahni
     

Diese Seite empfehlen