1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

Merkwürdiges Problem mit Netzwerkfreigaben

Dieses Thema im Forum "Computer & Co." wurde erstellt von emtewe, 8. Juni 2011.

  1. emtewe

    emtewe Lexikon

    Registriert seit:
    4. August 2004
    Beiträge:
    22.769
    Zustimmungen:
    2.964
    Punkte für Erfolge:
    213
    Anzeige
    Ich hatte gerade ein merkwürdiges Problem mit ein paar Netzwerkfreigaben. Ein alter Windows Server soll ausrangiert werden, und ich bin dabei Netzwerkfreigaben auf ein NAS zu übertragen.
    Ein Ordner der bisher auf dem Windows Server war, und "Daten" hiess, habe ich über Nacht komplett auf den NAS kopiert, und dort auch als "Daten" freigegeben. Dann habe ich auf den Einzelrechnern die alten Verbindungen zu den Netzwerklaufwerken "N:\" getrennt, und auf dem NAS neu eingerichtet. Für die Nutzer der Rechner änderte sich praktisch nichts, unter dem gleichen Laufwerksbuchstaben fanden sie die gleichen Daten, alle hatten die gleichen Zugriffsrechte.
    Dann stellte sich aber heraus, dass alle Nutzer ausser mir, auf einem Unterordner, nur Leserechte hatten. Im Verzeichnis "Daten" gabe es Unterordner (\DatenA, \DatenB, DatenC usw...) und auf einen davon konnten alle ausser mir nur lesend zugreifen, obwohl alle Nutzer auf Vollzugriff standen, und die gleichen Rechte hatten wie ich. Es schien also so, als hätte nur der Rechner der den Kopiervorgang durchgeführt hatte, Schreibrechte für einen der Ordner. Die Atttribute des Ordners hatte ich überprüft, der war nicht schreibgeschützt.
    Letztendlich hat das Umkopieren des Ordners Abhilfe geschaffen. Ich habe den Ordner umbenannt, dann einen neuen mit dem alten Namen erstellt, und alle Dateien aus dem unbenannten in den neuen mit altem Namen kopiert, danach war alles in Ordnung.

    Ich frage mich jedoch was das Problem verursacht haben könnte?
    Hat irgendjemand eine Idee?

    Ach ja, der Windows Server hatte "Windows2000 Server" als Betriebssystem, das NAS ist ein Qnap TS209, die Clients laufen mit Win2K, WinXP und Win7.

    Gruß
    emtewe
     
  2. Gag Halfrunt

    Gag Halfrunt Lexikon

    Registriert seit:
    26. November 2001
    Beiträge:
    22.648
    Zustimmungen:
    2
    Punkte für Erfolge:
    48
    AW: Merkwürdiges Problem mit Netzwerkfreigaben

    Klingt sehr danach, als wären die Zugriffsrechte eben nicht korrekt "vererbt" worden.
     
  3. emtewe

    emtewe Lexikon

    Registriert seit:
    4. August 2004
    Beiträge:
    22.769
    Zustimmungen:
    2.964
    Punkte für Erfolge:
    213
    AW: Merkwürdiges Problem mit Netzwerkfreigaben

    Die Zugriffsrechte habe ich ja neu definiert. Der Witz ist ja, alle anderen Unterordner haben auf Anhieb funktioniert, nur einer nicht. Und das obwohl ich ja nicht die Unterordner einzeln, sondern den übergeordneten Ordner komplett kopiert habe, auf welchen sich auch die Freigabe und Rechtevergabe bezieht.
     
  4. Gag Halfrunt

    Gag Halfrunt Lexikon

    Registriert seit:
    26. November 2001
    Beiträge:
    22.648
    Zustimmungen:
    2
    Punkte für Erfolge:
    48
    AW: Merkwürdiges Problem mit Netzwerkfreigaben

    Soll ich ehrlich sein? Ich zerbreche mir über sowas schon lange nicht mehr den Kopf, insbesondere wenn Windows und Linux zusammen spielen.
     
  5. emtewe

    emtewe Lexikon

    Registriert seit:
    4. August 2004
    Beiträge:
    22.769
    Zustimmungen:
    2.964
    Punkte für Erfolge:
    213
    AW: Merkwürdiges Problem mit Netzwerkfreigaben

    Was passiert ist, ist mir ja im Grunde egal, solange es nicht nochmal passiert. Ich würde in Zukunft natürlich gerne vermeiden dass sich sowas wiederholt, nur müsste man dafür verstehen wie es passiert ist.
    Aber du hast natürlich recht, wenn ich 2 Arbeitstage in das Thema investiere, um herauszufinden wo das Problem lag, dann kann man dafür auch ein paar neue Server kaufen. Von daher, abwarten was passiert, und wenn es sich wiederholt, neuer Server. Ist unter dem Strich wahrscheinlich billiger...;)
     

Diese Seite empfehlen