1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

image auslesen

Dieses Thema im Forum "d-box 1 und d-box 2" wurde erstellt von bmurki, 20. Mai 2002.

  1. bmurki

    bmurki Junior Member

    Registriert seit:
    23. April 2002
    Beiträge:
    55
    Ort:
    München
    Anzeige
    hi,

    ich habe jetzt endlich dei dbox im debug. nun kann ich aber das image nicht auslesen. ich bekomme immer folgende meldung:

    debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
    debug: BMon V1.0 mID 01
    debug: feID 7a gtxID 0b
    debug: fpID 5a dsID 01-aa.07.1d.07.00.00-20
    debug: HWrev X5 SWrev 0.81
    debug: B/Ex/Fl(MB) 32/00/08
    WATCHDOG reset enabled
    dbox2:root> debug:
    BOOTP/TFTP bootstrap loader (v0.3)
    debug:
    debug: Transmitting BOOTP request via broadcast
    debug: Given up BOOTP/TFTP boot
    boot net failed

    Flash-FS bootstrap loader (v1.5)

    Found Flash-FS superblock version 3.1
    File /root/platform/nokia-dbox2/kernel/os not found: No such file or directory
    boot flash /root/platform/nokia-dbox2/kernel/os failed

    Flash-FS bootstrap loader (v1.5)

    Found Flash-FS superblock version 3.1
    File /root/platform/mpc8xx-dbox2/kernel/os not found: No such file or directory
    boot flash /root/platform/mpc8xx-dbox2/kernel/os failed

    Flash-FS bootstrap loader (v1.5)

    Found Flash-FS superblock version 3.1
    Found file /root/platform/kernel/os in Flash-FS
    debug: Got Block #0048

    will verify ELF image, start= 0x800000, size= 1267512
    verify sig: 0
    Branching to 0x409b8
    debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
    debug: BMon V1.0 mID 01
    debug: feID 7a gtxID 0b
    debug: fpID 5a dsID 01-aa.07.1d.07.00.00-20
    debug: HWrev X5 SWrev 0.81
    debug: B/Ex/Fl(MB) 32/00/08
    WATCHDOG reset enabled
    dbox2:root> debug:
    BOOTP/TFTP bootstrap loader (v0.3)
    debug:
    debug: Transmitting BOOTP request via broadcast
    debug: Got BOOTP reply from Server IP 192.168.136.2, My IP 192.168.136.3
    debug: Sending TFTP-request for file C/dbox2/tftpboot/ppcboot
    will verify ELF image, start= 0x800000, size= 224356
    verify sig: 262
    boot net: boot file has no valid signature
    Branching to 0x40000

    ppcboot 0.6.4 (Jan 10 2002 - 16:35:20)

    Initializing...
    CPU: PPC823ZTnnA at 67 MHz: 2 kB I-Cache 1 kB D-Cache
    *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
    Board: ### No HW ID - assuming TQM8xxL
    DRAM: (faked) 32 MB
    Ethernet: 00-50-9c-1e-ab-93
    FLASH: 8 MB
    LCD driver (KS0713) initialized
    No LCD Logo in Flash , trying tftp
    BOOTP broadcast 1
    TFTP from server 192.168.136.2; our IP address is 192.168.136.3
    Filename 'C/dbox2/tftpboot/logo-lcd'.
    Load address: 0x130000
    Loading: ##
    done
    LCD logo at: 0x130000 (0x1FD2864 bytes)
    No FB Logo in Flash , trying tftp
    BOOTP broadcast 1
    TFTP from server 192.168.136.2; our IP address is 192.168.136.3
    Filename 'C/dbox2/tftpboot/logo-fb'.
    Load address: 0x120000
    Loading: ###
    done
    FB logo at: 0x0 (0x1FC0000 bytes)
    AVIA Frambuffer
    Input: serial
    Output: serial

    Images:
    1: cdk
    2: yadd
    3: debian
    4: tiab
    5: flash
    Select image (1-5), other keys to stop autoboot: 0
    BOOTP broadcast 1
    TFTP from server 192.168.136.2; our IP address is 192.168.136.3
    Filename 'C/dbox2/tftpboot/kernel-cdk'.
    Load address: 0x100000
    Loading: #######################################################################
    ###############################################
    done
    ## Booting Linux kernel at 00100000 ...
    Image Name: dbox2
    Image Type: PowerPC Linux Kernel Image (gzip compressed)
    Data Size: 600241 Bytes = 586 kB = 0 MB
    Load Address: 00000000
    Entry Point: 00000000
    Verifying Checksum ... OK
    Uncompressing Kernel Image ... OK
    Linux version 2.4.2 (root@noer-lab.noernet.de) (gcc version 3.0.1 20010702 (prer
    elease)) #89 Fri Aug 24 21:37:54 CEST 2001
    Boot arguments: console=ttyS0 root=/dev/nfs rw nfsroot=192.168.136.2:C/dbox2/cdk
    root/
    On node 0 totalpages: 8192
    zone(0): 8192 pages.
    zone(1): 0 pages.
    zone(2): 0 pages.
    Kernel command line: console=ttyS0 root=/dev/nfs rw nfsroot=192.168.136.2:C/dbox
    2/cdkroot/
    time_init: decrementer frequency = 251250000/60
    Warning: real time clock seems stuck!
    Console: colour dummy device 80x25
    Calibrating delay loop... 66.56 BogoMIPS
    Memory: 30624k available (1088k kernel code, 424k data, 64k init, 0k highmem)
    Dentry-cache hash table entries: 4096 (order: 3, 32768 bytes)
    Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
    Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
    Inode-cache hash table entries: 2048 (order: 2, 16384 bytes)
    POSIX conformance testing by UNIFIX
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Starting kswapd v1.8
    i2c-core.o: i2c core module
    CPM UART driver version 0.03
    ttyS00 at 0x0280 is a SMC
    pty: 256 Unix98 ptys configured
    block: queued sectors max/low 20264kB/6754kB, 64 slots per queue
    eth0: CPM ENET Version 0.2, 00:50:9c:1e:ab:93
    JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
    D-Box 2 flash driver (size->0x800000 mem->0x10000000)
    D-Box 2 flash memory: Found 2 x16 devices at 0x0 in 32-bit mode
    Creating 7 MTD partitions on "D-Box 2 flash memory":
    0x00000000-0x00020000 : "BR bootloader"
    0x00020000-0x000c0000 : "idxfs"
    0x000c0000-0x001c0000 : "var"
    0x001c0000-0x00760000 : "root"
    0x00760000-0x00800000 : "flfs"
    0x00020000-0x00800000 : "GesamteFlashOhneBL"
    0x007e0000-0x00800000 : "flfs_128"
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 2048 bind 4096)
    Sending BOOTP requests.... OK
    IP-Config: Got BOOTP answer from 192.168.136.2, my address is 192.168.136.3
    IP-Config: Guessing netmask 255.255.255.0
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    devfs: v0.102 (20000622) Richard Gooch (rgooch@atnf.csiro.au)
    devfs: boot_options: 0x0
    Looking up port of RPC 100003/2 on 192.168.136.2
    Looking up port of RPC 100005/2 on 192.168.136.2
    VFS: Mounted root (nfs filesystem).
    Warning: unable to mount devfs, err: -2
    Freeing unused kernel memory: 64k init
    Warning: unable to open an initial console.

    Ich habe es auch schon mit ppcboot_readfash vom bootmanager versucht. da wird das imge ausgelesen aber es ist fehlerhaft. wenn ich versuche die dateien zu extrahieren dann bekomme ich die meldung das camalpha.bin konnte im image nicht gefunden werden.
    ich hoffe ihr könnt mir weiterhelfen.

    gruß markus
     
  2. Frankieboy

    Frankieboy Gold Member

    Registriert seit:
    22. August 2001
    Beiträge:
    1.952
    du hast ein netzwerkproblem. die box bootet aus dem flash, nicht von der datei ppcboot_flash.

    der pc und die box handeln ihre netzwerkverbindung nicht schnell genug aus.

    richte mal alles so ein wie im readme.txt vom bootmanager beschrieben. mediasensing abschalten bei XP und 2000 mit dem MS patch, crossoverkabel (besser 10 mbit hub), bloß keinen switch verwenden, netzwerkkarte fest auf 10 mbit halfduplex einstellen, box nicht ausschalten, sondern nur resetten. dann löpt das auch.
     
  3. bmurki

    bmurki Junior Member

    Registriert seit:
    23. April 2002
    Beiträge:
    55
    Ort:
    München
    meine netzwerkarte ist auf 10mbit halfduplex eingestellt. mein betriebssystem ist windows me. so fällt das problem mit dem mediasensing schon mal weg. egal was ich mache ob resetten oder stecker ziehen es kommt immer dieselbe meldung. die einstellungen für die netzwerkkrate sind wie im readme vom bootmanager beschrieben. habt ihr vielleicht noch ne idee woran es liegen könnte?

    gruß

    markus
     
  4. Frankieboy

    Frankieboy Gold Member

    Registriert seit:
    22. August 2001
    Beiträge:
    1.952
    du siesht ja anhand der meldung

    debug: Transmitting BOOTP request via broadcast
    debug: Given up BOOTP/TFTP boot
    boot net failed

    das die box nicht übers netzwerk vom pc bootet. sondern aus dem flash (nächste meldung).

    andere netzwerkkarte probieren. realtek ist meistens totaler mist, weil die treiber murks sind. probiere mal eine intel oder 3com karte. ein 10 mbit hub hilft auch oft wunder.

    für t-dsl ist so eine realtek nämlich auch meistens mist. habe da so meine erfahrungen. läc meine 3com 3c905B auf 10 mbit halfduplex eingestellt löpt einwandfrei zum flashen. und für t-dsl. läc die 10 € für eine alte karte von intel oder 3com sollte es dir wert sein......
     
  5. olu

    olu Junior Member

    Registriert seit:
    26. Januar 2001
    Beiträge:
    103
    Ort:
    Deutschland
    Zur Zeit hab ich auch ein ähnliches Problem mit der gleichen Fehlermeldung. Ich arbeite mit einem Notebook und alles hatte bis vor kurzem einwandfrei funktioniert und plötzlich gings dann überhaupt nicht mehr. Also wirds nicht an der Netzwerkkarte oder den Netzwerkeinstellungen liegen. Ich wollte es mal heute abend mit einem anderen TFTP-Server versuchen. Vielleicht liegts ja daran?!

    Gruß,

    olu
     
  6. olu

    olu Junior Member

    Registriert seit:
    26. Januar 2001
    Beiträge:
    103
    Ort:
    Deutschland
    Hmm.. mit dem neuen TFTP Server war das doch nicht die Lösung des Problems. Kriege immer noch die gleiche Meldung.

    Weiss jemand, was es eigentlich bedeutet, wenn die Box beim Versuch zu flashen folgendes bringt:

    Loading: #####T ####T ###T .... usw.
    Retry.....

    oder

    Loading: T T T .... usw.
    Retry.....

    Gruß,

    olu
     
  7. Gorcon

    Gorcon Kanzler Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.250
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    Hi
    T...T Bedeutet Aussetzer im Datenstromdes Netzwerks.
    Versuch sonst mal alle nicht gebrauchten Programme zu deaktivieren falls das Problem immer noch auftritt. zB. Antivierenscanner Bildschirmschoner usw.
    Gruß Gorcon
     
  8. olu

    olu Junior Member

    Registriert seit:
    26. Januar 2001
    Beiträge:
    103
    Ort:
    Deutschland
    Hi Gorcon,

    dann könnte es doch evtl. was bringen, wenn ich einfach mal meine Netwerkkarte neu installiere, oder??

    ich versuch's heut abend einfach mal, danke!

    olu
     
  9. UlliHönes

    UlliHönes Silber Member

    Registriert seit:
    9. Februar 2001
    Beiträge:
    612
    Ort:
    Gestungshausen
    Technisches Equipment:
    Nokia SAT 2xI Avia600 GTX DBT-Image vom 15.01.2006
    Nokia SAT 2xI Avia500 GTX NovaTux-Image Release Neutrino 26.03.2006
    Ganz wichtig : Firewall deaktivieren (falls vorhanden)
     

Diese Seite empfehlen