1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

Ich komme einfach nicht in den Debug

Dieses Thema im Forum "d-box 1 und d-box 2" wurde erstellt von Achim-DrSchnaggels, 30. April 2002.

  1. Achim-DrSchnaggels

    Achim-DrSchnaggels Neuling

    Registriert seit:
    12. April 2002
    Beiträge:
    14
    Ort:
    Simmerath
    Anzeige
    Ich habe eine D-Box2 von Philips und hätte (wie wohl jeder hier) BN runter, aber das scheitert schon im Ansatz.

    Das habe ich gemacht:
    Netzwekverbindung hergestellt PC-IP 192.168.0.50
    Box-IP 192.168.0.60 SN bei beiden 255.255.255.0
    Serielle Verbimdung eingesteckt,
    den ganzen benötigten kram runter geladen.
    bBox-Bootloader installiert
    Wenn ich dann auf Start gehe wird die Box Pingbar, dann Flash-Reset durchgeführt (Pin 14 auf Masse), Box beibt auch mit "Lade ..." stehen, aber wenn ich help eingebe kommt:
    > help
    ! Couldn't connect to DBOX! (Timeout..?)
    und wenn ich Copy_all ausführe kommt:
    ... oder falscher BR-Kernel verwendet.
    Ja was will die Box von mir?

    Und was anders habe in der Redme vom Loader gelesen das in dem NFS-Server verzeichnis die cps.class liegen, also habe ich die aus dem Loader Verzeichnis darüber kopiert. War das richtig?

    Was mache ich denn da so falsch, habe das mit dem Zeitpunkt hunderte mal probiert aber immer das gleiche, ausser das ab und zu auf die Eingabe Help gar nicht kommt.

    Muss ich unter BootIP was angeben habe es mal mit der PPC-Boot versucht doch da kommt dann auch nur ne Fehlermeldung die ich nicht verstehe...

    HILFE ICH WILL NICHT MIT BN STERBEN!

    Achim
     
  2. Achim-DrSchnaggels

    Achim-DrSchnaggels Neuling

    Registriert seit:
    12. April 2002
    Beiträge:
    14
    Ort:
    Simmerath
    Wow 5Minuten nachdem ich den Bertrag beschrieben habe war es dann soweit, nach drei Tage des Tüfftelns, ist was passiert, leider meine Freude schnell gedämpft, da ein Fehler auf trat:

    Ein Fehler ist während der Ausführung des Scripts aufgetreten! Der Befehl "arun Indicator -v -V -i 4" Schlug fehl!

    Im RSH-Client steht das letztes:
    INIT: started aid=23
    ! Command timed out - didn´t get answer from dbox!

    Und im Com Terminal steht nix!
    Habe das mal nit einem anderem Kabel probiert kommt aber auch nix.

    Gleiche Fehlermeldung.

    Meine Frage bin ihc jetzt im Debug Modus oder nicht? Wenn nicht was tun ausschalten un alls nochmal probieren? (Das habe ich dann mal gemacht, noch mal kurz hochgefahrenn ob noch alles klappt. Alles wie vorher und weiter...)

    Was tun?
     
  3. Gorcon

    Gorcon Kanzler Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.297
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    Hi
    Wo hast Du was gelesen das ein Pin an masse gelegt werden muss? Ich habe 3,3V benutzt. winken
    Gruß Gorcon
     
  4. Achim-DrSchnaggels

    Achim-DrSchnaggels Neuling

    Registriert seit:
    12. April 2002
    Beiträge:
    14
    Ort:
    Simmerath
    Aufgrund zahlreicher Nachfrage im Forum und per PM hier eine kleine Anleitung zum Schreibschutz disable.

    http://www.tuxbox.berlios.de/forum/viewtopic.php?t=5475

    Erfinder dieser super Methode ist Testbild. Vielen Dank dafür!!!

    Beschreibung der Vorgehensweise von Testbild:
    Das mit dem Schreibschutz ist etwas komplizierter. Wer es genau wissen will, kann sich mal durch die Datenblätter der jeweiligen Hersteller durchkämpfen. Aber im Prinzip funktioniert das so (Beispiel Intel 28F320): Ein Flash-Speicher ist in Blocks unterteilt. Beim Einschalten der Betriebsspannung sind alle Blocks schreibgeschützt (lock). Durch Kommando kann man den Schreibschutz eines Blocks aufheben (unlock) und auch wieder setzen.

    Dann gibt es noch den 'lock-down' Zustand. Diesen schreibgeschützten Zustand kann man nicht mehr per Kommando zurücksetzen, sondern nur durch einen Reset (Pin 12, RP#) oder durch Aus-und Wiedereinschalten der Betriebsspannung. Mit dem Kurzschluß von Write Protect (Pin 14, WP#), also XH4/XH6, nach 3.3V hebt man den lock-down-Zustand nur für die Dauer des Kurzschlusses auf. Lock-down für die ersten 128k wird gleich im Bootloader gesetzt, mit Ausnahme der Nokias mit Bootloader 1.0, wenn ich mich nicht irre, denn da braucht man den zweiten Kurzschluß nicht.

    Es ist also auch möglich, den Schreibschutz mittels Reset auszuschalten. Das geht natürlich nur, wenn kein Programmcode aus dem Flash ausgeführt wird. Das ist der Fall, wenn man über das Netzwerk gebootet hat, also z.B. mit der Minflsh-Methode eine RSH aufgemacht hat. Dann tippt man vorsichtig mit einer an GND angeschlossenen Nadel kurz an einen Reset-Pin RP# (ist bei beiden Flashs durchverbunden), und führt dann das Debug-Script aus. Nach dem nächsten Reset oder Reboot der Box ist der Schreibschutz des Bootloaders wieder aktiv.
     

Diese Seite empfehlen