1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

Frage zu MPEG2-Fehlern

Dieses Thema im Forum "Digital TV über Kabel (DVB-C)" wurde erstellt von Martin_K, 26. Juni 2008.

  1. Martin_K

    Martin_K Platin Member

    Registriert seit:
    21. Mai 2008
    Beiträge:
    2.606
    Technisches Equipment:
    DVB-S Astra 19,2°
    DVB-C Unitymedia Hessen
    Anzeige
    Hallo,
    habe ein paar Fragen zu Fehlern, die oft im MPEG2-Videostream im TV auftreten.
    Wäre eigentlich besser aufgehoben in einem Forum "Digital TV allgemein", aber sowas scheints irgendwie nicht zu geben?!? Deswegen poste ich einfach mal hier, da ich Digital TV über Kabel (DVB-C) habe. Kann ja verschoben werden, wenn's hier falsch ist...

    Habe mal zwei Fehler rausgepickt, bei denen ich glaube, dass sie nichts mit einem Empfangsproblem meinerseits zu tun haben, sondern evtl. vom Sender bzw. vom Kabelanbieter (Unitymedia) so kommen.
    Leider kann ich keine Screenshots hochladen, aber vielleicht weiß ja jemand welche Fehler ich meine und kann evtl. Bilder dazu verlinken, dann kann ich sagen, ob es diese Fehler sind, die ich meine ;)

    Fehler 1:
    Betrifft nur ein einzelnes Frame.
    Das Frame hat an einigen Stellen über die Bildfläche verteilt (ca. 10 Stück) anders farbige Bereiche (ca. 8x8 Pixel groß), diese Bereiche sind aber nicht komplett anders farbig, sondern hier nur vereinzelte Punkte, die wie ein Raster verteilt sind.
    Das sieht etwa so aus:
    .....
    .....
    ...
    Das wäre jetzt ein solcher Bereich, wobei die Punkte enger aneinader sind, die letzte Zeile aber meißtens rechts weniger Punkte hat. Natürlich ist das ganze auch quadratisch...
    Innerhalb eines Bereiches sind die Punkte einfarbig.
    Die Farben sind meißtens weiß, grün oder rosa.
    Dieser Fehler tritt äußerst selten auf und man muss schon genau hinschauen, um ihn zu bemerken, da es ja nur ein einzelnes Frame ist.
    Er hat nichts mit einer zu niedrigen Bitrate zu tun, da er auch bei ARD & Co. auftritt.

    Fehler 2:
    Dieser Fehler hat sehr wohl etwas mit niederiger Bitrate zu tun, er tritt nur bei den Privaten auf (RTL, Pro7 & Co.).
    Hier ist eine extreme Klötzchenbildung zu sehen, ein Klötzchen (ca. 8x8 Pixel) ist hier komplett einfarbig, jedoch ist es die Farbe, die auch zum Bild gehört und kein weiß/grün/rosa wie oben.
    Ich meine NICHT die bekannte Klötzchenbildung aufgrund niedriger Bitrate bei schnellen Filmszenen, eher im Gegenteil: tritt meißtens bei ruhigen Passagen auf, häufig wenn von einem schnellen Bildwechsel auf ein Standbild gewechselt wird. Dann ist beim Wechsel das Standbild so verpixelt, nicht jedoch die bewegte Szene davor!
    Es sind auch mehrere Frames betroffen, ich würde mal sagen eine GOP.
    Habe übrigens festgestellt, dass dieses Problem - beim selben Privatsender - über DVB-T nicht besteht, sondern ausschließlich über Kabel. Muss also evtl. an der Neucodierung durch Unitymedia liegen?!?


    Nun hoffe ich, dass ihr mir folgende Fragen beantworten könnt:
    Woher kommen diese Fehler, wer verursacht sie?
    Wie entstehen diese Fehler? Wie kann man (oder ich als Empfänger, falls möglich) sie verhinder?

    Danke schonmal für eure Antworten ;)
     
  2. paul71

    paul71 Board Ikone

    Registriert seit:
    23. Mai 2005
    Beiträge:
    4.508
    AW: Frage zu MPEG2-Fehlern

    Du musst erstmal ausschliessen, dass solche Fehler nicht durch die Datenuebertragung entstehen. Wenn gewisse Blocks nicht rekonstruiert weden koennen, hat es genau solche Effekte - nur die Ursachen koennen unterschiedlich sein. Entweder fdoch alsches/fehlerhaftes Encoding, oder die Daten kommen nicht an - muesste mit hohen BER-Werten einhergehen. Genau koennte man es sagen, wenn man die streams anlaysiert...
     
  3. Martin_K

    Martin_K Platin Member

    Registriert seit:
    21. Mai 2008
    Beiträge:
    2.606
    Technisches Equipment:
    DVB-S Astra 19,2°
    DVB-C Unitymedia Hessen
    AW: Frage zu MPEG2-Fehlern

    Also um fehlende Pakete oder Discontinuities handelt es sich bei diesen Fehlern nicht. Was sind denn BER-Werte? Haben den Begriff hier schon oft gelesen, aber keine Ahnung was es ist...
    Bin mir zu 90% sicher, dass diese beim Encoding entstehen, der 2. Fehler vermutlich beim neu Encodieren durch den Kabelnetzbetreiber UM und bei Fehler 1 wahrscheinlich schon vom Sender her. Wäre mal interessant zu wissen, ob es solche Fehler (vor allem Fehler 1) auch über Sat gibt...
     
  4. »»-MiB-««

    »»-MiB-«« Institution

    Registriert seit:
    15. November 2005
    Beiträge:
    18.951
    Ort:
    - Die MACHT am Rhein ! - Leverkusen
    AW: Frage zu MPEG2-Fehlern

    hohe BER Werte sind doch Standard bei QAM 256,oder ?
    Nach der Qualitätsvernichtungsoffensive von UM habe ich 500- 1000 bei BER , vorher 0-10.
    Seitdem bleiben auch ARD ZDF usw.auch gerne mal 30-60 sekunden stehen bevor ich wieder ein Bild habe. Vorher war das nicht.
     
  5. Gorcon

    Gorcon Moderator Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.350
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    AW: Frage zu MPEG2-Fehlern

    Nein, Nur wenn die Kabelnetzbetreiber ihre Leitungen nicht mindestens alle 10 Jahre komplett erneuern.
    Bei der BER dürfte so ein extremer Bildausfall aber noch nicht geschehen.
     
  6. paul71

    paul71 Board Ikone

    Registriert seit:
    23. Mai 2005
    Beiträge:
    4.508
    AW: Frage zu MPEG2-Fehlern

    Natürlich nicht, hohe BER Werte sind nie Standard sondern immer ein Problem.
    Die BER (Bit-Error-Ratio) gibt den Anteil von fehlerhaften oder fehlenden Bit-Paketen zur Menge der insegsamt empfangenen Daten berechnet anhand der übertragenen Kontrollmechanismen. Bei MPEG-Video oder Audio bis zu einer gewissen Grenze noch zu verkraften, bei Datenübertragung oder Telefonie tödlich.. Wie willst du denn wissen, ob es sich um dicontiuities handelt oder nicht, wenn du den Stream und die erreichten BERs nicht kennst? Es ist wie gesagt möglich, dass die Enkodierung schief läuft, in diesem Fall wäre die BER niedrig bzw. nicht auffällig, da ja alle gesendeten Daten auch ankommen. Üblich sind diese Fehler aber nicht - ich kann bei den streams der KabelD. oder Sat-direkt von solchen Effekten nicht berichten...
     
    Zuletzt bearbeitet: 28. Juni 2008
  7. Martin_K

    Martin_K Platin Member

    Registriert seit:
    21. Mai 2008
    Beiträge:
    2.606
    Technisches Equipment:
    DVB-S Astra 19,2°
    DVB-C Unitymedia Hessen
    AW: Frage zu MPEG2-Fehlern

    Stopp!!!
    Keine Diskussion hier über die Qualitätsoffensive!
    Wer Probleme seit der QAM 256 Umstellung hat, soll mal seine Hausverteilung checken lassen. Ein neuer HAV und ein Receiver mit einem moderneren Tuner und diese Probleme waren bei mir weg!
    Aber diese zwei Fehler haben absolut nichts mit der Qualitätsoffensive zu tun, da sie vorher schon genauso da waren, auch bei QAM 64.

    So und jetzt bleibt bitte beim Thema, lest euch meinen ersten Post nochmal durch und antwortet nur, wenn ihr darauf eine Antwort habt.
    Ich hoffe, dass ich mal Screenshots davon machen kann, damit es deutlicher wird, welche Fehler ich meine.
    Und sagt mir mal bitte einer was BER überhaupt ist...
     
  8. paul71

    paul71 Board Ikone

    Registriert seit:
    23. Mai 2005
    Beiträge:
    4.508
    AW: Frage zu MPEG2-Fehlern

    Oha, irgendwie hast du gepostet, während ich meinen Beitrag abgeschickt habe, bitte lesen...
     
  9. Martin_K

    Martin_K Platin Member

    Registriert seit:
    21. Mai 2008
    Beiträge:
    2.606
    Technisches Equipment:
    DVB-S Astra 19,2°
    DVB-C Unitymedia Hessen
    AW: Frage zu MPEG2-Fehlern

    @paul71: Doch ich kenne den Stream und ich kann zu 100% sagen, dass es keine Discontinuities sind! Die bekomme ich nämlich angezeigt beim DVB-Source im DVBViewer. Auf jedenfall sind es keine Fehler im Stream!

    Und nochmal:
    Fehler 2 kommt denke ich mal durch UM, Fehler 1 gibt es überall und ich bin mir fast sicher, dass es den auch über Sat geben muss. Fehler 1 fällt praktisch gar nicht auf, da es nur ein einzelnes Frame ist, in dem einzelne, ganz kleine Bereiche, also so kleine Kästchen, eine andere Farbe haben. Das fällt auch nur auf, wenn man sehr genau hinschaut oder sich die Frames einzeln betrachtet.

    Nochmal zu Fehler 2:
    Vielleicht hat ja auch der ein oder andere Prison Break auf RTL verfolgt. Hier war es ja so, dass es ab und zu bei spannenden Stellen schnelle Bildfolgen gab (z.B. Kamera sehr schnell durch eine Straße), danach das Bild kurz schwarz.
    Hier war es dann immer so, und ja es war bei so einer Stelle IMMER!, das diese schnellen Bildfolgen noch recht scharf waren (bis auch die üblichen Kästchen bei niederiger Bitrate), aber wenn dann das schwarze Bild kam, trat Fehler 2 auf, das Bild wurde ganz grob pixelig (da es schwarz ist nur am RTL Logo zu erkennen, das nur noch aus weißen 8x8-Blöcken bestand), während das Logo zuvor (bei den schnellen Bildfolgen) noch scharf war!
    Es trat wie gesagt bei solch einer Stelle immer auf, über DVB-T jedoch nie. Und mit einer zu niedrigen Bitrate kann es auch nichts zu tun haben, da das Bild hier ja nur schwarz ist, was ja nun wirklich keine hohe Bitrate braucht.
     
    Zuletzt bearbeitet: 28. Juni 2008
  10. Martin_K

    Martin_K Platin Member

    Registriert seit:
    21. Mai 2008
    Beiträge:
    2.606
    Technisches Equipment:
    DVB-S Astra 19,2°
    DVB-C Unitymedia Hessen
    AW: Frage zu MPEG2-Fehlern

    So, mir ist es jetzt gelungen, Screenshots von diesem Fehler (oben beschrieben als Fehler 2) zu machen:

    I-Frame:
    [​IMG]
    das darauf folgende B-Frame:
    [​IMG]
    Ausschnitt des betreffenden MPEG2-Streams:
    http://www.file-upload.net/download-1045446/video_beispiel.m2v.html

    von diesem Fehler ist die ganze GOP betroffen (am meisten das I-Frame), die Bitrate liegt jedoch bei 2085 kBit/s.
    An einer zu niedrigen Bitrate kann es also nicht liegen (man beachte auch das RTL2-Logo unten rechts), da die GOPs davor und danach die gleiche Szene zeigen und eine ähnliche Bitrate haben, das Bild ansich aber einwandfrei ist.
    Jemand ne Idee, woher diese Fehler kommt? Ein Empfangsproblem schließe ich wie gesagt aus (keine fehlenden Pakete), da ich mit ProjectX die entsprechende Stelle analysiert habe und es wurde keine Warnmeldung o. ä. ausgegeben.
    Meine Vermutung ist nachwievor, dass es an Fehlern bei der Neucodierung durch Unitymedia liegt, die Privaten werden doch neu codiert, oder?
    Hat jemand ähnliches Beobachtet oder kann mir sagen woher solche Fehler kommen?
    Meistens treten sie dann auf, wenn von einer bewegten Szene in ein Standbild gewechselt wird (vgl. Prison Break) oder von einem Standbild in eine bewegte Szene. Manchmal (wie im Screenshot) aber auch einfach so, mitten in einer Szene, wo sich nicht gerade sehr viel bewegt...

    Hier noch ein Screenshot (auch RTL2) nur von einem schwarzen Bild:
    [​IMG]
    Ausschnitt des betreffenden MPEG2-Streams:
    http://www.file-upload.net/download-1045444/video_schwarz.m2v.html
    Die Szene vor dem Schwarz war in Ordnung, erst die GOP als das Bild ganz schwarz ist weist diese Fehler auf!
     

Diese Seite empfehlen