1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

Demuxen - Tonspur kürzer als Video

Dieses Thema im Forum "Heimkino mit dem PC" wurde erstellt von andimaurer, 13. Mai 2004.

  1. andimaurer

    andimaurer Junior Member

    Registriert seit:
    8. Februar 2002
    Beiträge:
    57
    Ort:
    Gelsenkirchen
    Anzeige
    Hallo,

    ich habe angefangen, mich um Videobearbeitung am PC zu kümmern, bin also noch Anfänger in der Materie.

    Ich habe einen Film auf Festplatte aufgezeichnet und möchte diesen nun auf DVD überspielen. Ich habe den Film mit einem Schneideprogramm in mehrere Teile geschnitten, damit die Werbung draußen ist.

    Nun wollte ich ihn mit DVD-Lab bearbeiten, um ihn dann auf DVD brennen zu können. Nachdem DVD-Lab eins der MPG-Files eingelesen hat, muss ich feststellen, dass der Videotrack länger ist als der Audiotrack. Der Ton scheint schneller zu laufen, denn der Unterschied zwischen Bild und Ton wird im Laufe der Zeit immer größer.

    Ich habe keine Ahnung, woran der Fehler liegt, denn in den MPG-Dateien stimmen Bild und Ton überein.

    Kann jemand von Euch helfen?
     
  2. h2d

    h2d Guest

    Versuche doch mal mit Project_X zu demuxen und schau Dir das Protokoll an, ob der Stream OK ist.

    Gruß Dieter
     
  3. andimaurer

    andimaurer Junior Member

    Registriert seit:
    8. Februar 2002
    Beiträge:
    57
    Ort:
    Gelsenkirchen
    Danke für die schnelle Hilfe! Ich habe ProjectX jetzt seit knapp 2 Stunden auf dem Rechner und bekomme es mit dem Programm zumindest hin, dass Ton und Video die gleiche Länge haben.

    Aber: Der Ton hat jetzt leider Sprungstellen (so alle 5-10 Sekunden fehlen ein paar ms). Ich habe schon so ziemlich alle Einstellungen durchprobiert, aber ich kriege die Sprungstellen nicht weg.

    Seltsamerweise fällt vom Ton etwas weg, obwohl die Tonspur bei DVD-Lab ja kürzer war als die Videosput.

    Irgendeine Idee zu den Tonproblemen? Übrigens kriege ich zum Video bei ProjectX folgende (Fehler-)meldungen:

    => File is MPEG-2 PS/SS (Video/Audio PES)

    => demux

    -> found PES-ID 0xE0 (MPEG Video) @ 14

    -> found PES-ID 0xC0 (MPEG Audio) @ 155662

    -> video basics: 720*576 @ 25fps @ 0.6735 (4:3) @ 6000800bps, vbvBuffer 112

    -> starting export of video data @ GOP#0

    !> dropping GOP#5 @ orig.PTS 00:02:38.119 (14230710)

    Pics exp/cnt 14/14, inGOP PTS diff. -35ms, new Timecode 00:00:02.600

    !> dropping GOP#18 @ orig.PTS 00:02:44.917 (14842530)

    Pics exp/cnt 14/14, inGOP PTS diff. -29ms, new Timecode 00:00:08.840

    !> dropping GOP#28 @ orig.PTS 00:02:50.156 (15314040)

    Pics exp/cnt 14/14, inGOP PTS diff. -34ms, new Timecode 00:00:13.520

    !> dropping GOP#41 @ orig.PTS 00:02:56.955 (15925950)

    Das mit den Pics exp(ected?)/cnt (current?) wiederholt sich noch ziemlich oft bis zum Ende des Files.

    Ich habe schon mit den Einstellungen rumprobiert ohne Ende - aber kein Erfolg.

    Irgendeine Idee?
     
  4. h2d

    h2d Guest

    Die Grundeinstellungen bei Project_X sind eigentlich OK, da braucht man selten etwas zu verändern. Es scheint so, als ob der Stream fehlerhaft recordert wurde. Womit machst Du denn Deine Aufnahmen (HW/SW) ? Ist die Quelle digital oder analog ?
     
  5. Gorcon

    Gorcon Kanzler Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.304
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    Von welchem Sender hast Du denn gestreamt?
    Kann es sein das der verschiedene Datenraten für Audio verwendet?
    Gruß Gorcon
     
  6. h2d

    h2d Guest

    Noch ein paar Fragen: Schickst Du den ungeschnittenen Stream durch Project_X oder den geschnittenen ? Der ungeschnittene Stream sollte fehlerfrei sein. Womit schneidest Du ?
     
  7. andimaurer

    andimaurer Junior Member

    Registriert seit:
    8. Februar 2002
    Beiträge:
    57
    Ort:
    Gelsenkirchen
    Mein Videorecorder-Prog. heisst PowerVCR II, der Dateneingang ist über die TV-Karte per SVHS-Kabel.

    Die Einstellung ist "Aufnahme in DVD-Qualität", leider wird Audio aufgenommen als 44,1 khz (durchgehend, keine verschiedenen Raten). Das ist aber kein Problem, denn DVD-Lab kann es auf 48 khz umwandeln.

    Und wie schon gesagt, im vom digitalen Videorecorder erzeugten MPG-File sind Ton und Bild synchron. Nur eben in DVD-Lab nicht mehr. Und bei TPMGEnc Author habe ich auch das Problem mit der Asynchronität, auch wenn dort die Länge der Video- und Audiospur nicht explizit dargestellt werden.
     
  8. andimaurer

    andimaurer Junior Member

    Registriert seit:
    8. Februar 2002
    Beiträge:
    57
    Ort:
    Gelsenkirchen
    Ich schicke den geschnittenen durch. Aber auch nach dem Schneiden sind im MPG-File Bild und Ton synchron.

    Zum Schneiden verwende ich Vidomi.
     
  9. Gorcon

    Gorcon Kanzler Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.304
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    Dann hast Du aber diese Knackser drinn!
    Gruß Gorcon
     
  10. andimaurer

    andimaurer Junior Member

    Registriert seit:
    8. Februar 2002
    Beiträge:
    57
    Ort:
    Gelsenkirchen
    Danke für die schnellen Antworten!

    Sind die fehlerhaften khz schuld am vermurksten Ton? Wenn ja, wie kann man das umgehen? Es muss doch eine Möglichkeit geben, das Ganze irgendwie umzuwandeln?!
     

Diese Seite empfehlen