1. Cookies optimieren die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklärst Du dich damit einverstanden, dass wir Cookies verwenden. Weitere Informationen
    Information ausblenden
  2. Willkommen im Forum von DIGITAL FERNSEHEN - dem führenden Portal für digitales Fernsehen, Medien und Entertainment. Wenn du hier neu bist, schau dich ruhig etwas um und melde dich an, um am Forengeschehen teilnehmen zu können.
    Information ausblenden

D-Box 2 Sagem lädt nicht mehr

Dieses Thema im Forum "d-box 1 und d-box 2" wurde erstellt von gratai, 10. April 2004.

  1. gratai

    gratai Neuling

    Registriert seit:
    10. April 2004
    Beiträge:
    5
    Ort:
    Hamburg
    Anzeige
    Hilfe, meine D-Box von Sagem mit Originalsoftware lädt nicht mehr.

    Die Box versucht zu starten und bricht dann immer wieder ab. Manchmal bleibt sie auch beim Laden einfach stehen.

    Die Box ist noch im Originalzustand. Ist evtl. die Bootdatei beschädigt. Könnte man sie dann einfach durch die Linux Software ersetzen.

    Wo in Hamburg könnte man dieses vornehmen lassen, da ich zuwenig Kenntnisse habe.

    Vielen Dank
    Gratai
     
  2. Gorcon

    Gorcon Kanzler Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.268
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    Wenn der Bootloader beschädigt ist ist es für Linux auch zu späht. sch&uuml Solange aber die Box noch anfängt das Betriebsystem zu laden ist er i.O..
    Ich hatte mit der BN Soft auch sehr oft diese Probleme. Der Neustart hatte manchmal 10-15min gedauert.
    In einigen fällen hilft auch ein Flash Erease zu machen oder die Box dazu zwingen die Software komplett neu zu laden.
    Gruß Gorcon
     
  3. gratai

    gratai Neuling

    Registriert seit:
    10. April 2004
    Beiträge:
    5
    Ort:
    Hamburg
    Vielen Dank Gorcon. Ich habe aber noch 2 Zusatzfragen:

    Wenn der Bootloader beschädigt ist ist es für Linux auch zu späht. Solange aber die Box noch anfängt das Betriebsystem zu laden ist er i.O..

    Frage : Die Box starte und bleibt immer stehen bei "Lade . . ." Weiter geht es dann nicht mehr. Ist es für Linux zu spät?


    In einigen fällen hilft auch ein Flash Erease zu machen oder die Box dazu zwingen die Software komplett neu zu laden.

    Frage: Wie kann man das machen?

    Vielen Dank im voraus.

    Kratai

    PS: Kennt niemand eine gute ung günstige Adresse in Hamburg wo man die Box reparieren und ggfs. auf Linux umstellen lassen kann?
     
  4. Gorcon

    Gorcon Kanzler Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.268
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    Nein.
    Wenn sie nicht weiter als bis "Lade..." kommt geht kein Flash Erease. (Ich hatte angenommen die Box noch etwas weiter kommt. sch&uuml
    Gruß Gorcon
     
  5. Thrakhath

    Thrakhath Wasserfall

    Registriert seit:
    2. März 2001
    Beiträge:
    9.906
    Ich hatte mal eine Sagem, die evtl. dasselbe Problem hatte.

    Da kamen zunächst ein paar Kästchen, dann 'Lade...', dann wieder ein paar Kästchen und wieder 'Lade...' usw.

    Die Box konnte ich mit minflsh ohne Probleme in den Debug bringen. Das muss natürlich nichts heißen, da es durchaus mehrere Ursachen für das Problem geben kann.

    Solltest Du aber über das Equipment für den Linuxumbau verfügen (Nullmodemkabel, 10mBit taugliche Netzwerkkarte, Netzwerkverbindung über Crossover oder über 10mBit tauglichen Hub/Switch), dann wäre es einen Versuch wert (siehe Dietmar-H ).
     
  6. gratai

    gratai Neuling

    Registriert seit:
    10. April 2004
    Beiträge:
    5
    Ort:
    Hamburg
    Es wurde nun Neutrino auf die Box (Sagem 1xFlash, Kabel) gespielt. Wie bei der Originalsoftware stoppt die Box. Jetzt stoppt die Box bei "starting kernel".

    Das Protokoll vom Start füge ich bei. Weiß jemand Rat?

    Vielen Dank
    Gratai


    debug: DDF: Calibrating delay loop... debug: DDF: 66.8269 BogoMIPS
    debug: BMon V1.2 mID 03
    debug: feID 00 enxID 03
    debug: fpID 52 dsID 01-6c.33.89.07.00.00-79
    debug: HWrev 61 FPrev 0.23
    debug: B/Ex/Fl(MB) 32/00/08
    WATCHDOG reset enabled
    dbox2:root> debug:
    BOOTP/TFTP bootstrap loader (v0.3)
    debug:
    debug: Transmitting BOOTP request via broadcast
    debug: Given up BOOTP/TFTP boot
    boot net failed

    Flash-FS bootstrap loader (v1.5)

    Found Flash-FS superblock version 3.1
    Found file /root/platform/sagem-dbox2/kernel/os in Flash-FS
    debug: Got Block #0052

    will verify ELF image, start= 0x800000, size= 202740
    verify sig: 262
    Branching to 0x40000


    PPCBoot 1.1.6 (TuxBox) (Jul 12 2002 - 21:12:06)

    CPU: PPC823ZTnnB2 at 66 MHz: 2 kB I-Cache 1 kB D-Cache
    Watchdog enabled
    Board: DBOX2, Sagem
    I2C: ready
    DRAM: 32 MB
    FLASH: 8 MB
    Scanning JFFS2 FS: . done.
    find_inode failed for name=ppcboot.conf
    load: Failed to find inode
    LCD: ready
    FB: loading - ready
    In: serial
    Out: serial
    Err: serial

    Options:
    1: Console on null
    2: Console on ttyS0
    3: Console on framebuffer
    Select (1-3), other keys to stop autoboot: 0
    ### FS (cramfs) loading 'vmlinuz' to 0x100000
    ### FS load compleate: 590500 bytes loaded to 0x100000
    ## Booting image at 00100000 ...
    Image Name: dbox2
    Image Type: PowerPC Linux Kernel Image (gzip compressed)
    Data Size: 590436 Bytes = 576 kB = 0 MB
    Load Address: 00000000
    Entry Point: 00000000
    Verifying Checksum ... OK
    Uncompressing Kernel Image ... OK
    Linux version 2.4.22-dbox2 (von alexW) (gcc version 3.2.3) #1 So Nov 2 19:55:35
    CET 2003
    On node 0 totalpages: 8192
    zone(0): 8192 pages.
    zone(1): 0 pages.
    zone(2): 0 pages.
    Kernel command line: root=/dev/mtdblock2 console=ttyS0
    Decrementer Frequency = 247500000/60
    mpc8xx-wdt: active wdt found (SWTC: 0xFFFF, SWP: 0x1)
    mpc8xx-wdt: keep-alive trigger activated (PITC: 0x2000)
    Console: colour dummy device 80x25
    Calibrating delay loop... 65.74 BogoMIPS
    Memory: 30936k available (1008k kernel code, 364k data, 60k init, 0k highmem)
    Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
    Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
    Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
    POSIX conformance testing by UNIFIX
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
    devfs: boot_options: 0x1
    JFFS2 version 2.1. (C) 2001, 2002 Red Hat, Inc., designed by Axis Communications
    AB.
    i2c-core.o: i2c core module
    CPM UART driver version 0.03
    ttyS00 at 0x0280 is a SMC
    ttyS01 at 0x0380 is a SMC
    pty: 256 Unix98 ptys configured
    eth0: CPM ENET Version 0.2 on SCC2, 00:50:9c:3b:46:3b
    D-Box 2 flash driver (size->0x800000 mem->0x10000000)
    CFI: Found no D-Box 2 flash memory device at location zero
    D-Box 2 flash memory: Found 1 x16 devices at 0x0 in 16-bit mode
    Intel/Sharp Extended Query Table at 0x0031
    cfi_cmdset_0001: Erase suspend on write enabled
    Using buffer write method
    Creating 6 MTD partitions on "D-Box 2 flash memory":
    0x00000000-0x00020000 : "BR bootloader"
    0x00020000-0x00040000 : "flfs (ppcboot)"
    0x00040000-0x00720000 : "root (cramfs)"
    0x00720000-0x00800000 : "var (jffs2)"
    0x00020000-0x00800000 : "flash without bootloader"
    0x00000000-0x00800000 : "complete flash"
    Linux video capture interface: v1.00
    mice: PS/2 mouse device common for all mice
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 2048 bind 4096)
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    VFS: Mounted root (cramfs filesystem) readonly.
    Mounted devfs on /dev
    Freeing unused kernel memory: 60k init
    Inconsistency detected by ld.so: dl-minimal.c: 4655748558: malloc: Assertion `pa
    ge != ((void *) -1)' failed!
    Kernel panic: Attempted to kill init!
    <0>Rebooting in 180 seconds..
     
  7. Gorcon

    Gorcon Kanzler Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.268
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    Einfach nochmal neu flashen.
    Ich würde da aber ein aktuelles JtG Image verwenden.
    Gruß Gorcon
     
  8. gratai

    gratai Neuling

    Registriert seit:
    10. April 2004
    Beiträge:
    5
    Ort:
    Hamburg
    Ich komme einfach nicht weiter. Ein Auslesen oder flashen mit dem Bootmanager ist nicht möglich. Die Box stoppt immer bei - siehe unten - und nichts passiert mehr:

    Inconsistency detected by ld.so: dl-minimal.c: 4655748558: malloc: Assertion `pa
    ge != ((void *) -1)' failed!
    Kernel panic: Attempted to kill init!
    <0>Rebooting in 180 seconds..

    Was mag nur die Ursache sein. Kann man nicht aus dieser Meldung einen Grund ableiten? Was bedeutet sie?

    Dort wo man die Software draufgespielt hatte, wußte man auch nicht weiter.

    Viel Hoffnung habe ich nicht mehr. Wahrscheinlich ist es ein Hardwaredefekt und eine Reparatur lohnt sich nicht.

    Vielen Dank für die Hilfe
    Gratai
     
  9. Gorcon

    Gorcon Kanzler Mitarbeiter

    Registriert seit:
    15. Januar 2001
    Beiträge:
    107.268
    Ort:
    Schwerin
    Technisches Equipment:
    Coolstream Zee², HD1
    Die Meldung sagt nicht viel aus.
    Ich schätze aber Du wirsd weiter oben die Fehlermeldung boot net failed haben. winken
    Gruß Gorcon
     

Diese Seite empfehlen